[Fusionforge-commits] r14315 - branches/Branch_5_1/src/debian

Thorsten Glaser mirabilos at fusionforge.org
Mon Sep 5 13:08:19 CEST 2011


Author: mirabilos
Date: 2011-09-05 13:08:19 +0200 (Mon, 05 Sep 2011)
New Revision: 14315

Modified:
   branches/Branch_5_1/src/debian/changelog
   branches/Branch_5_1/src/debian/control
Log:
refresh after r14313 changes


Modified: branches/Branch_5_1/src/debian/changelog
===================================================================
--- branches/Branch_5_1/src/debian/changelog	2011-09-05 11:07:35 UTC (rev 14314)
+++ branches/Branch_5_1/src/debian/changelog	2011-09-05 11:08:19 UTC (rev 14315)
@@ -9,9 +9,11 @@
   * Fixed Provides: in -plugin-scmgit.
 
   [ Thorsten Glaser ]
+  * Move php-htmlpurifier dependency into gforge-common because it
+    contains scripts requiring it, which are called from its postinst.
   * Check for presence of dependencies before regenerating control.
 
- -- Thorsten Glaser <t.glaser at tarent.de>  Mon, 05 Sep 2011 13:06:44 +0200
+ -- Thorsten Glaser <tg at mirbsd.de>  Mon, 05 Sep 2011 13:07:45 +0200
 
 fusionforge (5.1-5) unstable; urgency=low
 

Modified: branches/Branch_5_1/src/debian/control
===================================================================
--- branches/Branch_5_1/src/debian/control	2011-09-05 11:07:35 UTC (rev 14314)
+++ branches/Branch_5_1/src/debian/control	2011-09-05 11:08:19 UTC (rev 14315)
@@ -70,7 +70,7 @@
 
 Package: gforge-common
 Architecture: all
-Depends: debconf (>= 1.0.32) | debconf-2.0, ucf, cpio, lockfile-progs, adduser, php5-cli, libphp-simplepie, python, ${misc:Depends}
+Depends: debconf (>= 1.0.32) | debconf-2.0, ucf, cpio, lockfile-progs, adduser, php5-cli, php-htmlpurifier (>= 4.0), libphp-simplepie, python, ${misc:Depends}
 Conflicts: sourceforge, gforge-plugin-scmcvs (<< 4.1), gforge-plugin-scmsvn (<< 4.1), gforge-plugin-scmccase (<< 4.1), gforge-theme-starterpack (<< 4.0)
 Description: collaborative development tool - shared files
  FusionForge provides many tools to aid collaboration in a
@@ -84,7 +84,7 @@
 
 Package: gforge-web-apache2
 Architecture: all
-Depends: gforge-common, gforge-db-postgresql | gforge-db, libapache2-mod-php5, php5-cgi, php5-pgsql, php5-gd, perl, libdbi-perl, libdbd-pg-perl, debianutils (>= 1.7), debconf (>= 1.0.32) | debconf-2.0, ucf, cronolog, python, ssl-cert, libnusoap-php, php-htmlpurifier (>= 4.0), libphp-simplepie, libjs-yui, libjs-scriptaculous, libjs-jquery, libjs-jquery-tipsy, libphp-jpgraph, ${misc:Depends}
+Depends: gforge-common, gforge-db-postgresql | gforge-db, libapache2-mod-php5, php5-cgi, php5-pgsql, php5-gd, perl, libdbi-perl, libdbd-pg-perl, debianutils (>= 1.7), debconf (>= 1.0.32) | debconf-2.0, ucf, cronolog, python, ssl-cert, libnusoap-php, libphp-simplepie, libjs-yui, libjs-scriptaculous, libjs-jquery, libjs-jquery-tipsy, libphp-jpgraph, ${misc:Depends}
 Recommends: locales | locales-all
 Provides: gforge-web
 Conflicts: gforge-web
@@ -126,7 +126,7 @@
 
 Package: gforge-db-postgresql
 Architecture: all
-Depends: gforge-common, postgresql (>= 8.4), perl, libdbi-perl, libdbd-pg-perl, libmime-base64-perl, libhtml-parser-perl, libtext-autoformat-perl, libmail-sendmail-perl, libsort-versions-perl, debianutils (>= 1.7), debconf (>= 1.0.32) | debconf-2.0, ucf, php5-cli, php5-pgsql, php-htmlpurifier, ${misc:Depends}
+Depends: gforge-common, postgresql (>= 8.4), perl, libdbi-perl, libdbd-pg-perl, libmime-base64-perl, libhtml-parser-perl, libtext-autoformat-perl, libmail-sendmail-perl, libsort-versions-perl, debianutils (>= 1.7), debconf (>= 1.0.32) | debconf-2.0, ucf, php5-cli, php5-pgsql, ${misc:Depends}
 Provides: gforge-db
 Conflicts: gforge-db
 Description: collaborative development tool - database (using PostgreSQL)




More information about the Fusionforge-commits mailing list